0.5.1+7

  • Updates to Pigeon 13.

0.5.1+6

  • Adds pub topics to package metadata.
  • Updates minimum supported SDK version to Flutter 3.7/Dart 2.19.

0.5.1+5

  • Fixes the behavior of no type groups to allow selecting any file.
  • Migrates styleFrom usage in examples off of deprecated primary and onPrimary parameters.

0.5.1+4

  • Updates references to the deprecated macUTIs.

0.5.1+3

  • Updates pigeon to fix warnings with clang 15.
  • Updates minimum Flutter version to 3.3.

0.5.1+2

  • Updates to pigeon version 9.

0.5.1+1

  • Clarifies explanation of endorsement in README.
  • Aligns Dart and Flutter SDK constraints.

0.5.1

  • Updates minimum Flutter version to 3.3 and iOS 11.

0.5.0+3

  • Updates links for the merge of flutter/plugins into flutter/packages.
  • Updates example code for use_build_context_synchronously lint.
  • Updates minimum Flutter version to 3.0.

0.5.0+2

  • Changes XTypeGroup initialization from final to const.
  • Updates minimum Flutter version to 2.10.

0.5.0+1

  • Updates README for endorsement.

0.5.0

  • Initial iOS implementation of file_selector.