0.8.6

  • Adds usePhotoPickerAndroid options.

0.8.5+10

  • Clarifies explanation of endorsement in README.
  • Aligns Dart and Flutter SDK constraints.

0.8.5+9

  • Fixes compilation warnings.
  • Updates compileSdkVersion to 33.

0.8.5+8

  • Adds Android 13 photo picker functionality if SDK version is at least 33.
  • Bumps compileSdkVersion from 31 to 33

0.8.5+7

  • Updates links for the merge of flutter/plugins into flutter/packages.

0.8.5+6

  • Updates minimum Flutter version to 3.0.
  • Fixes names of picked files to match original filenames where possible.

0.8.5+5

  • Updates code for stricter lint checks.

0.8.5+4

  • Fixes null cast exception when restoring a cancelled selection.

0.8.5+3

  • Updates minimum Flutter version to 2.10.
  • Bumps gradle from 7.1.2 to 7.2.1.

0.8.5+2

  • Updates image_picker_platform_interface constraint to the correct minimum version.

0.8.5+1

  • Switches to an internal method channel implementation.

0.8.5

  • Updates gradle to 7.1.2.

0.8.4+13

  • Minor fixes for new analysis options.

0.8.4+12

  • Fixes library_private_types_in_public_api, sort_child_properties_last and use_key_in_widget_constructors lint warnings.

0.8.4+11

  • Splits from image_picker as a federated implementation.