[flutter_markdown] Fix changelog regarding minimum supported SDK version (#4851)

The changelog of the `flutter_markdown` package is a bit confusing. First it says:

> Updates minimum supported SDK version to Flutter 3.10/Dart 3.0

and in the latest update is says

> Updates minimum supported SDK version to Flutter 3.7/Dart 2.19

Just from reading this I would expect that the minimum SDK lowered with the latest update. However, this is not the case.

After a bit of researching, I found this was caused by https://github.com/flutter/packages/pull/4731. The mentioned PR only updates the minimum SDK of the example but not of the package, see: https://github.com/flutter/packages/pull/4731/files#diff-e780ee3aec5fdc10512b452b5464878a11caf22fb23d28f725324308ad243d17R6

Therefore, I clarified the changelog with this PR.


<img width="819" alt="image" src="https://github.com/flutter/flutter/assets/24459435/bee2f046-ea86-45c7-9567-a19949e3e6f8">

Fixes https://github.com/flutter/flutter/issues/134056

*If you had to change anything in the [flutter/tests] repo, include a link to the migration guide as per the [breaking change policy].*
diff --git a/packages/flutter_markdown/CHANGELOG.md b/packages/flutter_markdown/CHANGELOG.md
index 8132e9f..8c77da8 100644
--- a/packages/flutter_markdown/CHANGELOG.md
+++ b/packages/flutter_markdown/CHANGELOG.md
@@ -1,7 +1,10 @@
+## 0.6.17+3
+* Fixes an incorrect note about SDK versions in the 0.6.17+2 CHANGELOG.md entry.
 ## 0.6.17+2
 * Adds pub topics to package metadata.
-* Updates minimum supported SDK version to Flutter 3.7/Dart 2.19.
 ## 0.6.17+1
diff --git a/packages/flutter_markdown/pubspec.yaml b/packages/flutter_markdown/pubspec.yaml
index abd38cc..683f188 100644
--- a/packages/flutter_markdown/pubspec.yaml
+++ b/packages/flutter_markdown/pubspec.yaml
@@ -4,7 +4,7 @@
   formatted with simple Markdown tags.
 repository: https://github.com/flutter/packages/tree/main/packages/flutter_markdown
 issue_tracker: https://github.com/flutter/flutter/issues?q=is%3Aissue+is%3Aopen+label%3A%22p%3A+flutter_markdown%22
-version: 0.6.17+2
+version: 0.6.17+3
   sdk: ">=3.0.0 <4.0.0"