blob: cd5d28e127f8c6f8d28ed31c905c06e492b1cbae [file] [log] [blame]
Dieter Baron4a3c42b2008-06-17 11:06:42 +02001# RPM spec for libzip
2# This was tested on OpenSUSE 10.3 x86_64; should build fine on 32bit SUSE
3# and other distributions, as it uses the system-defined macros for
4# installation locations etc.
5
6Name: libzip
Dieter Baron270129f2008-07-25 12:54:16 +02007Version: 0.9
Dieter Baron4a3c42b2008-06-17 11:06:42 +02008Release: 1
9Group: System/Libraries
10License: BSD
11Packager: Stephen Bryant <steve@bawue.de>
12BuildRoot: %{_tmppath}/%{name}-%{version}-build
13Source0: %{name}-%{version}.tar.gz
14Requires: zlib >= 1.1.2
15BuildRequires: zlib-devel >= 1.1.2, grep, make
16URL: http://www.nih.at/libzip/
17Summary: Library for reading, creating, and modifying zip archives
18%description
19This is libzip, a C library for reading, creating, and modifying zip archives.
20Files can be added from data buffers, files, or compressed data copied directly
21from other zip archives. Changes made without closing the archive can be
22reverted. The API is documented by man pages.
23
24
25%package devel
26Summary: Include files and libraries needed for development
27Group: Development/Languages/C and C++
28Requires: zlib-devel
29%description devel
30This is libzip, a C library for reading, creating, and modifying zip archives.
31Files can be added from data buffers, files, or compressed data copied directly
32from other zip archives. Changes made without closing the archive can be
33reverted. The API is documented by man pages.
34
35For more information, take a look at the included man pages. You can start with
36libzip(3), which lists all others.
37
38There is a mailing list for libzip. You can subscribe to it by sending a mail
39with the subject "subscribe libzip-discuss" to minimalist at nih.at.
40
41%prep
42%setup
43
44%build
45%configure
46%{__make} -j$(($(%{__grep} -E '^processor' /proc/cpuinfo|wc -l)+1))
47
48%install
49%{__make} DESTDIR=${RPM_BUILD_ROOT} install
50
51%clean
52%{__rm} -rf ${RPM_BUILD_ROOT}
53
54%files
55%defattr(-,root,root)
56%{_prefix}/bin
57%{_libdir}/*.so
58%{_libdir}/*.so.*
59%{_mandir}/man1
60
61%files devel
62%defattr(-,root,root)
63%{_prefix}/include
64%{_libdir}/*.a
65%{_libdir}/*.la
66%{_libdir}/pkgconfig
67%{_mandir}/man3
68
69%post
70ldconfig
71
72%postun
73ldconfig